日期:2014-05-20  浏览次数:20756 次

hdu 1065 我用C过了,但java过不了。。
http://acm.hdu.edu.cn/showproblem.php?pid=1065
I Think I Need a Houseboat

I Think I Need a Houseboat

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3344 Accepted Submission(s): 1113


Problem Description


Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion. 

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.) 


 

Input
The first line of input will be a positive integer indicating how many data sets will be included (N). 

Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.
 

Output
For each data set, a single line of output should appear. This line should take the form of: 

“Property N: This property will begin eroding in year Z.” 

Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. 

After the last data set, this should print out “END OF OUTPUT.” 

Notes: 

1. No property will appear exactly on the semicircle boundary: it will either be inside or outside. 

2. This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines. 

3. All locations are given in miles.
 

Sample Input

1.0 1.0 
25.0 0.0
 

Sample Output
Property 1: This property will begin eroding in year 1. 
Property 2: This property will begin eroding in year 20. 
END OF OUTPUT. 
 

Java code

/*
2011-9-1
author:BearFly1990
*/


import java.io.BufferedInputStream;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(new BufferedInputStream(System.in));
        int j,k;
        int n;
        double x,y,area;
       
        n = in.nextInt();
        for(int i = 1; i <= n ; i++){
            x = in.nextDouble();
            y = in.nextDouble();
            area = ((x*x + y*y)*3.1415926)/2.0;
            int z = (int)(area/50.0)+1;
            System.out.printf("Property %d: This property will begin eroding in year %d.",i,z);
            System.out.println();
        }
        System.out.printf("END OF OUTPUT.");
        System.out.println();
    }
            
    
}

 




------解决方案--------------------
这道题是能过的,我以前页折腾了很久。
------解决方案--------------------
看java程序没啥问题,lz问什么呢?