日期:2014-5-16 浏览次数:20147次

redhat 5 搭建postfix安装imap问题
[root@localhost pub]# rpm -ivh imap-2001a-18.i386.rpm
warning: imap-2001a-18.i386.rpm: Header V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
  libcom_err.so.3 is needed by imap-2001a-18.i386
  libcrypto.so.4 is needed by imap-2001a-18.i386
  libssl.so.4 is needed by imap-2001a-18.i386
怎么解决,高手们赐教

------解决方案--------------------
错误已经很明白了 缺少库 libcom_err.so.3 libcrypto.so.4 libssl.so.4
你把这三个库先安装了就好了 
话说回来 redhat支持yum吧 你怎么不用yum安装imap呢
------解决方案--------------------
#yum install imap

估计你刚学不久,yum源也不会配置吧。简单给你说说,不行上网搜。
估计你是有安装光盘的。把光盘挂上。
然后修改yume配置文件。具体路径我记不清了,
/etc/yum.conf/yum.resp/XXXX_debug_XXX.resp

把里面的baseurl改称
baseurl=光盘所在路径 + Server
enable=1
gpgcheck=0
然后保存

在执行yum install imap